interiorcad millings such as drillings, contour routings and dados are hidden by default via their class. Each milling has its own class and all attributes are governed by the class it’s been auto-assigned to: line thickness is zero and the texture (‘NC-Transparent’) has 100% transparency. This ensures that these custom millings don’t get in the way visually but can still be selected. You can just about see the selection highlighting in the image below:

interiorcad_contour_hidden
Contour rendered ‘Shaded Solid’
interiorcad_contour
Contour rendered ‘Hidden Line’

So, why are these millings still visible in Hidden Line, sections and Renderworks rendered viewports?

Hidden Line does not support texture transparency (only ‘none’ fills) and Renderworks, depending on your settings, may still show the transparent object (mostly in the case of miters but also contours):
To get around this, simply hide the class in your viewports. With the viewport selected, find the “Classes…” button in the Object Info Palette. Bring up the Classes dialog and search for “Contour” (or the equivalent milling you want to hide).

Vectorworks-Viewport-Class-Properties
Contour class hidden

Make sure it’s hidden, confirm the dialog and update your viewport.
The contour should now be gone from your renderings.